Q1:通达信怎么把下面的代码改成选股器,我需要短牛,中牛,大牛都筛选出来

以下选股公式是可以同时选出小牛中牛大牛的公式:
N1:=5;
N2:=10;
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*10,COLORFF00FF,LINETHICK1;
RSI10:=SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*10,COLOR00FFFF;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
XG:BT OR TJ1 OR TJ2;

Q2:超牛指标,请高手加一个同时满足“短牛”“中牛”“大牛”的选股公式

闪牛分析:转载,仅供参考!
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0);
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
短牛:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
中牛:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
大牛:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
选三牛合一:短牛+中牛+大牛=3;

Q3:帮忙改通达信选股公式?

RSV:=(((CLOSE - LLV(LOW,(牛熊骨 + 3))) / (HHV(HIGH,(牛熊骨 + 3)) - LLV(LOW,19))) * 100);
FASTK:=(((SMA(RSV,8,1) - 50) * 1.4) + 50);
D:=SMA(FASTK,8,1);
SSS:=SMA(D,8,1);
XG:SSS>= REF(SSS,1) AND SSS<20;
试试这个吧,参数自己设一下,不行Q我

Q4:通达信 买牛 选股公式

BOLL2:=MA(CLOSE,20);
UB:=BOLL2+2*STD(CLOSE,20);
LB:=BOLL2-2*STD(CLOSE,20);
BZ:=BOLL2#WEEK;
线5日:=MA(CLOSE,5);
线25日:=MA(CLOSE,25);
XG:CROSS(C,UB) AND CROSS(C,BZ) AND 线25日>REF(线25日,1) AND 线5日>线25日;

Q5:通达信15分钟k线图当天收盘股价在60分钟线上面选股公式

c>ma(c,60);

关键是在制止了选股是加入后先选选股周期,切记。

希望能帮到你。

Q6:通达信公式中,15分钟的周期怎么表示的,求高人写下,

1.先建立一个公式,取名801c,内容为:
JC:C;
JH:H;
JL:L;
JO:O;
2.在其它公式中才能引用其它周期收盘价。如:5分钟钟表达式为:
收盘价5分:801c.JC#MIN5;
{软件只能在小周期里调用大周期,例在1分钟K线下调用5分钟,在5分钟K线下调用15分钟、30分钟等。
如果回答满意,请记得给采纳}